ERRO Phpmyadmin – Warning in ./libraries/plugin_interface.lib.php – count(): Parameter must be an array or an object that implements Countable

estava com este problema no phpmyadmin:

Warning in ./libraries/plugin_interface.lib.php#551
count(): Parameter must be an array or an object that implements Countable

porém a solução deste site resolveu meu problema:
http://agoracomlinux.blogspot.com/2019/01/resolvendo-problemas-pos-instalacao-do.html

Warning in ./libraries/plugin_interface.lib.php#551
 count(): Parameter must be an array or an object that implements Countable

$ sudo nano /usr/share/phpmyadmin/libraries/plugin_interface.lib.php

onde aparecerá isso

troque isso

if ($options != null && count($options) > 0) {

por isso

if ($options != null && count((array)$options) > 0) {

 

PROBLEMA COM PHPMYADMIN AND PHP 7.2: “WARNING IN ./LIBRARIES/SQL.LIB.PHP#613 COUNT(): PARAMETER MUST BE AN ARRAY OR AN OBJECT THAT IMPLEMENTS COUNTABLE”

 Faça uma cópia de segurança primeiro

sudo cp /usr/share/phpmyadmin/libraries/sql.lib.php /usr/share/phpmyadmin/libraries/sql.lib.php.bak

Edite o sql.lib.php no Deepin Editor

sudo nano /usr/share/phpmyadmin/libraries/sql.lib.php

Pressione CTRL+W e procure por

(count($analyzed_sql_results[‘select_expr’] == 1)

troque por

((count($analyzed_sql_results['select_expr']) == 1)

 

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair /  Alterar )

Foto do Google

Você está comentando utilizando sua conta Google. Sair /  Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair /  Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair /  Alterar )

Conectando a %s